Standard South China Access Point is being upgraded

Incident Report for Nexitally

Resolved

This incident has been resolved.
Posted Jun 01, 2020 - 07:56 UTC

Identified

Standard South China Access Point is being upgraded
Posted May 31, 2020 - 12:44 UTC
This incident affected: Servers / Access Points (Standard South China Access Point).